summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8abbdaf..ecc8d49 100644
--- a/configure.in
+++ b/configure.in
@@ -1223,7 +1223,18 @@ AC_SUBST(CC_VERSION)
if test "X-$cc_vendor" != "X-" && test "X-$cc_version" != "X-"; then
CC_VERSION="$CC ($cc_vendor-$cc_version)"
else
- CC_VERSION="$CC"
+ # If $CC contains directory component, take it as is;
+ # else search it among PATH components.
+ if `echo $CC | grep / 2>&1 /dev/null`; then
+ CC_VERSION="$CC"
+ else
+ for x in `echo $PATH | sed -e 's/:/ /g'`; do
+ if test -x $x/$CC; then
+ CC_VERSION="$x/$CC"
+ break
+ fi
+ done
+ fi
fi