summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f94b621..8abbdaf 100644
--- a/configure.in
+++ b/configure.in
@@ -332,6 +332,9 @@ AC_CHECK_SIZEOF(float, 4)
AC_CHECK_SIZEOF(double, 8)
AC_CHECK_SIZEOF(long double, 8)
+dnl Checkpoint the cache
+AC_CACHE_SAVE
+
dnl Posix.1g types (C9x)
cat >>confdefs.h <<\EOF
#include <sys/types.h>
@@ -398,6 +401,9 @@ case $HSIZET in
;;
esac
+dnl Checkpoint the cache
+AC_CACHE_SAVE
+
dnl ----------------------------------------------------------------------
dnl Is HDF4 present? If so then we can compile the h5toh4 converter. We
dnl assume h5toh4 can be compiled and then prove otherwise when we don't find
@@ -692,6 +698,9 @@ AC_CHECK_LIB(pdb,PD_open)
AC_CHECK_LIB(silo,lite_PD_open)
AC_CHECK_HEADERS(pdb.h,PDB2HDF=pdb2hdf)
+dnl Checkpoint the cache
+AC_CACHE_SAVE
+
dnl ----------------------------------------------------------------------
dnl Is the Pthreads library present? It has a header file `pthread.h' and
dnl a library `-lpthread' and their locations might be specified with the
@@ -962,6 +971,9 @@ else
CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
fi
+dnl Checkpoint the cache
+AC_CACHE_SAVE
+
dnl ----------------------------------------------------------------------
dnl The following variables are used to distinguish between building a
dnl serial and parallel library.