summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 54ab501..def7f6e 100644
--- a/configure.in
+++ b/configure.in
@@ -3811,10 +3811,10 @@ dnl
AC_SUBST([DEFAULT_API_VERSION])
AC_MSG_CHECKING([which version of public symbols to use by default])
AC_ARG_WITH([default-api-version],
- [AC_HELP_STRING([--with-default-api-version=(v16|v18)],
+ [AC_HELP_STRING([--with-default-api-version=(v16|v18|v110)],
[Specify default release version of public symbols
- [default=v18]])],,
- withval=v18)
+ [default=v110]])],,
+ withval=v110)
if test "X$withval" = "Xv16"; then
AC_MSG_RESULT([v16])
@@ -3824,13 +3824,16 @@ if test "X$withval" = "Xv16"; then
elif test "X$withval" = "Xv18"; then
AC_MSG_RESULT([v18])
DEFAULT_API_VERSION=v18
+elif test "X$withval" = "Xv110"; then
+ AC_MSG_RESULT([v110])
+ DEFAULT_API_VERSION=v110
else
AC_MSG_ERROR([invalid version of public symbols given])
fi
dnl It's an error to try to disable deprecated public API symbols while
dnl choosing an older version of the public API as the default.
-if test "X${DEFAULT_API_VERSION}" != "Xv18" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
+if test "X${DEFAULT_API_VERSION}" != "Xv110" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
AC_MSG_ERROR([Removing old public API symbols not allowed when using them as default public API symbols])
fi