summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9c04f7a..32e46e9 100644
--- a/configure.in
+++ b/configure.in
@@ -389,8 +389,10 @@ dnl --------------------------------------------------------------------
dnl See if the fortran compiler supports the intrinsic function "SIZEOF"
AC_MSG_CHECKING([if Fortran compiler supports intrinsic SIZEOF])
- AC_TRY_COMPILE(,[
- i = sizeof(x)
+ AC_TRY_RUN([
+ PROGRAM main
+ i = sizeof(x)
+ END PROGRAM
], [AC_MSG_RESULT(yes)
HAVE_SIZEOF="yes"],
AC_MSG_RESULT(no))