summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1686261..4df9317 100644
--- a/configure.in
+++ b/configure.in
@@ -93,7 +93,7 @@ dnl ----------------------------------------------------------------------
dnl Check for header files.
dnl
AC_HEADER_STDC
-
+AC_CHECK_HEADERS(unistd.h)
dnl ----------------------------------------------------------------------
@@ -125,6 +125,11 @@ AC_CHECK_SIZEOF(long, 4)
AC_CHECK_SIZEOF(long long, 8)
AC_CHECK_SIZEOF(float, 4)
AC_CHECK_SIZEOF(double, 8)
+AC_CHECK_SIZEOF(size_t, 4)
+cat >>confdefs.h <<\EOF
+#include <sys/types.h> /*for off_t definition*/
+EOF
+AC_CHECK_SIZEOF(off_t, 4)