summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index dc50acd..f961247 100644
--- a/configure.in
+++ b/configure.in
@@ -155,7 +155,7 @@ else
fi
dnl ----------------------------------------------------------------------
-dnl Check if they would like the Fortran interface compiled
+dnl Check if they would like the C++ interface compiled
dnl
AC_MSG_CHECKING(if c++ interface enabled)
AC_ARG_ENABLE(cxx,
@@ -489,6 +489,21 @@ case $HSIZET in
;;
esac
+dnl ----------------------------------------------------------------------
+dnl Check if they would like the HDF5 v1.2 compatibility functions compiled in
+dnl
+AC_MSG_CHECKING(whether HDF5 v1.2 compatibility functions enabled)
+AC_ARG_ENABLE(hdf5v1_2,
+ [ --enable-hdf5v1_2 Compile the HDF5 v1.2 compatibility interface [default=no]],
+ HDF5_V1_2_COMPAT=$enableval)
+
+if test "X$HDF5_V1_2_COMPAT" = "Xyes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WANT_H5_V1_2_COMPAT)
+else
+ AC_MSG_RESULT(no)
+fi
+
dnl Checkpoint the cache
AC_CACHE_SAVE