summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 994e739..7ac71fb 100644
--- a/configure.in
+++ b/configure.in
@@ -2658,6 +2658,35 @@ if test 1 = 2; then
[Define if shared writing must be disabled (CodeWarrior only)])
fi
+dnl --------------------------------------------------------------------------
+dnl Should the Default Virtual File Driver be compiled?
+dnl
+
+AC_MSG_CHECKING([for Default Virtual File Driver definition])
+AC_ARG_WITH([default-vfd],
+ [AC_HELP_STRING([--with-default-vfd=driver],
+ [Specify default file driver
+ [default=]])],,
+ withval=)
+
+if test "X$withval" = "Xsec2"; then
+ AC_MSG_RESULT([yes])
+ default_vfd=yes
+ vfd_define=H5FD_SEC2
+elif test "X$withval" = "Xstdio"; then
+ AC_MSG_RESULT([yes])
+ default_vfd=yes
+ vfd_define=H5FD_STDIO
+else
+ AC_MSG_RESULT([no])
+ default_vfd=no
+fi
+
+if test "X$default_vfd" = "Xyes"; then
+ AC_DEFINE_UNQUOTED([DEFAULT_VFD], [$vfd_define],
+ [Define the default virtual file driver to compile])
+fi
+
dnl -----------------------------------------------------------------------------
dnl Should the Stream Virtual File Driver be compiled in ?
dnl