summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 3f726f7..f14cf56 100644
--- a/configure.in
+++ b/configure.in
@@ -511,8 +511,17 @@ AC_PROG_MAKE_SET
AC_PROG_INSTALL
-
dnl ----------------------------------------------------------------------
+dnl Check that the tr utility is working properly.
+
+AC_PATH_PROG(TR, tr)
+
+TR_TEST=`echo Test | ${TR} ${as_cr_letters}"," ${as_cr_LETTERS}" "`
+if test "X${TR_TEST}" != "XTEST"; then
+ AC_MSG_ERROR([tr program doesn't work])
+fi
+
+
dnl The following variables are used to distinguish between building a
dnl serial and parallel library.
dnl
@@ -573,7 +582,7 @@ case "$CC_BASENAME" in
if (echo $cmd | grep / >/dev/null); then
path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH | tr : ' '`; do
+ for path in `echo $PATH | ${TR} ":" " "`; do
if test -x $path/$cmd; then
break
fi
@@ -604,7 +613,7 @@ case "$CC_BASENAME" in
if (echo $cmd | grep / >/dev/null); then
path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH | tr : ' '`; do
+ for path in `echo $PATH | ${TR} ":" " "`; do
if test -x $path/$cmd; then
break
fi
@@ -662,7 +671,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
if (echo $cmd |grep / >/dev/null); then
path="`echo $cmd |sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH | tr : ' '`; do
+ for path in `echo $PATH | ${TR} ":" " "`; do
if test -x $path/$cmd; then
break;
fi
@@ -1027,6 +1036,7 @@ AC_CHECK_LIB([m], [ceil])
if test "`uname`" = "SunOS" -o "`uname -sr`" = "HP-UX B.11.00"; then
dnl ...for Solaris
+ AC_CHECK_LIB([socket], [socket])
AC_CHECK_LIB([nsl], [xdr_int])
fi
@@ -1999,7 +2009,7 @@ case "X-$DEBUG_PKG" in
esac
if test -n "$DEBUG_PKG"; then
- for pkg in `echo $DEBUG_PKG | tr ${as_cr_letters}',' ${as_cr_LETTERS}' '`; do
+ for pkg in `echo $DEBUG_PKG | ${TR} ${as_cr_letters}"," ${as_cr_LETTERS}" "`; do
H5_CPPFLAGS="$H5_CPPFLAGS -DH5${pkg}_DEBUG"
done
fi