summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index df1630d..7ad5f34 100644
--- a/configure.in
+++ b/configure.in
@@ -143,6 +143,7 @@ AC_HEADER_STDC
AC_HEADER_TIME
dnl Unix
AC_CHECK_HEADERS(sys/resource.h sys/time.h unistd.h sys/ioctl.h sys/stat.h)
+AC_CHECK_HEADERS(stddef.h)
dnl Windows
AC_CHECK_HEADERS(io.h winsock.h sys/timeb.h)
@@ -304,6 +305,15 @@ AC_DEFINE(HAVE_TM_GMTOFF)
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
+dnl check if `struct tm' has a `__tm_gmtoff' member.
+AC_MSG_CHECKING(for __tm_gmtoff in struct tm)
+AC_TRY_COMPILE([
+#include <sys/time.h>
+#include <time.h>],[struct tm tm; tm.__tm_gmtoff=0;],
+AC_DEFINE(HAVE___TM_GMTOFF)
+AC_MSG_RESULT(yes),
+AC_MSG_RESULT(no))
+
dnl Check whether the global variable `timezone' is defined.
AC_MSG_CHECKING(for global timezone variable)
AC_TRY_LINK([