summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index e5b6bb5..b4f36af 100644
--- a/configure.in
+++ b/configure.in
@@ -126,13 +126,13 @@ dnl ----------------------------------------------------------------------
dnl Check for libraries. (none required yet)
dnl
AC_CHECK_LIB(coug, main) dnl ...for ASCI/Red
-
+AC_CHECK_LIB(z, compress2)
dnl ----------------------------------------------------------------------
dnl Check for header files.
dnl
AC_HEADER_STDC
-AC_CHECK_HEADERS(unistd.h)
+AC_CHECK_HEADERS(unistd.h zlib.h)
dnl ----------------------------------------------------------------------
@@ -176,7 +176,7 @@ esac
dnl ----------------------------------------------------------------------
dnl Check for functions.
dnl
-AC_CHECK_FUNCS(getpwuid gethostname system)
+AC_CHECK_FUNCS(getpwuid gethostname system getrusage)
AC_TRY_COMPILE([#include<sys/types.h>],
[off64_t n = 0;],
@@ -214,9 +214,9 @@ AC_ARG_ENABLE(debug,
is most packages.],
DEBUG_PKG=$enableval)
-all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v"
+all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
if test X = "X$DEBUG_PKG" -o Xyes = "X$DEBUG_PKG"; then
- DEBUG_PKG=ac,b,d,e,f,g,hg,i,mm,p,s,t,v
+ DEBUG_PKG=ac,b,d,e,f,g,hg,i,mm,p,s,t,v,z
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(default ($DEBUG_PKG))
elif test Xall = "X$DEBUG_PKG"; then