summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b6ad467..be8f2b4 100644
--- a/configure.in
+++ b/configure.in
@@ -778,6 +778,10 @@ dnl Shared C++ libraries seem not to work on some platforms (modi4, shanti)
dnl when the -xarch=v9 flag is used to enable 64-bit mode.
dnl Try to detect the -xarch=v9 flag and disable C++ shared libraries if it's
dnl being used.
+dnl Also disable C++ shared libraries if shared libraries are disabled.
+dnl this prevents Automake from trying to link against shared libraries,
+dnl which caused problems on tg-login
+H5_CXX_SHARED="no"
if test "X${HDF_CXX}" = "Xyes" && test "X${enable_shared}" != "Xno"; then
H5_CXX_SHARED="yes"