summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index aeaaa39..7b29de6 100644
--- a/configure.in
+++ b/configure.in
@@ -281,9 +281,11 @@ AC_PROG_LIBTOOL
dnl Post processing to patch up some deficiencies in libtool
case $host_os in
linux*)
- # If an Intel compiler is used, it needs to set $wl to use "-Wl,"
- if $CC -V 2>&1 | grep '^Intel(R)' > /dev/null ; then
- echo 'fix $wl in' $ofile
+ # If gcc is not used, need to set $wl to use "-Wl,"
+ if $CC -v 2>&1 | grep '^gcc' > /dev/null ; then
+ : using gcc
+ else
+ echo 'fix $wl in' $ofile
ed - $ofile <<EOF 2> /dev/null
/^wl=""/s//wl="-Wl,"/
w