summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b7caccd..71fd657 100644
--- a/configure.in
+++ b/configure.in
@@ -1932,6 +1932,13 @@ AC_TRY_COMPILE(,[(void)__FUNCTION__],
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no]))
+AC_MSG_CHECKING([for __offsetof__ extension])
+AC_TRY_COMPILE(,[size_t __offsetof__(unused)],
+ AC_DEFINE([HAVE_OFFSETOF], [1],
+ [Define if the __offsetof__ extension is present])
+ AC_MSG_RESULT([yes]),
+ AC_MSG_RESULT([no]))
+
dnl ----------------------------------------------------------------------
dnl Try to figure out how to print `long long'. Some machines use `%lld'
dnl and others use `%qd'. There may be more! The final `l' is a