summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in67
1 files changed, 67 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3f046da..8476064 100644
--- a/configure.in
+++ b/configure.in
@@ -86,9 +86,43 @@ else
AC_MSG_RESULT(no)
fi
+dnl ----------------------------------------------------------------------
+dnl Production flags?
+dnl
+AC_MSG_CHECKING(for production mode)
+AC_ARG_ENABLE(production,
+ [--enable-production=yes|no Determines how to run the compiler.])
+
+case "X-$enableval" in
+ X-yes)
+ AC_MSG_RESULT("production")
+ CFLAGS="$CFLAGS $PROD_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $PROD_CPPFLAGS"
+ ;;
+ X-|X-no)
+ AC_MSG_RESULT("development")
+ CFLAGS="$CFLAGS $DEBUG_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $DEBUG_CPPFLAGS"
+ ;;
+ X-pg|X-profile)
+ AC_MSG_RESULT("profile")
+ CFLAGS="$CFLAGS $PROFILE_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $PROFILE_CPPFLAGS"
+ ;;
+ *)
+ AC_MSG_RESULT("user-defined")
+ ;;
+esac
dnl ----------------------------------------------------------------------
+dnl Turn on warning flags for gcc.
+dnl
+if test Xyes = "X$GCC"; then
+ CFLAGS="$CFLAGS -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs"
+fi
+
+dnl ----------------------------------------------------------------------
dnl Check for libraries. (none required yet)
dnl
AC_CHECK_LIB(coug, main) dnl ...for ASCI/Red
@@ -157,6 +191,39 @@ AC_TRY_COMPILE(,[int f(void){return __FUNCTION__;}],
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
+dnl ----------------------------------------------------------------------
+dnl Turn on debugging by setting compiler flags
+dnl
+AC_MSG_CHECKING(for debug flags);
+AC_ARG_ENABLE(debug,
+ [--enable-debug=all Turn on debugging in all packages. One may also
+ specify a comma-separated list of package names
+ without the leading H5 or the word no. The default
+ is most packages.],
+ DEBUG_PKG=$enableval)
+
+all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v"
+if test X = "X$DEBUG_PKG" -o Xyes = "X$DEBUG_PKG"; then
+ DEBUG_PKG=ac,b,d,e,f,g,hg,hl,i,mf,mm,p,s,t,v
+ CPPFLAGS="$CPPFLAGS -UNDEBUG"
+ AC_MSG_RESULT(default ($DEBUG_PKG))
+elif test Xall = "X$DEBUG_PKG"; then
+ DEBUG_PKG=$all_packages
+ CPPFLAGS="$CPPFLAGS -UNDEBUG"
+ AC_MSG_RESULT(all ($DEBUG_PKG))
+elif test Xno = "X$DEBUG_PKG" -o Xnone = "X$DEBUG_PKG"; then
+ AC_MSG_RESULT(none)
+ DEBUG_PKG=
+ CPPFLAGS="$CPPFLAGS -DNDEBUG"
+else
+ AC_MSG_RESULT($DEBUG_PKG)
+fi
+
+if test "X" != "X$DEBUG_PKG"; then
+ for pkg in `echo $DEBUG_PKG | tr 'a-z,' 'A-Z '`; do
+ CPPFLAGS="$CPPFLAGS -DH5${pkg}_DEBUG"
+ done
+fi
dnl ----------------------------------------------------------------------
dnl Check for parallel support