summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 19b3c4b..f8921e3 100644
--- a/configure.in
+++ b/configure.in
@@ -2895,16 +2895,17 @@ dnl (This flag should be _unset_ for all machines, except for Windows, where
dnl it's set in the custom Windows H5pubconf.h file)
dnl
AC_MSG_CHECKING([if the machine has window style path name])
-AC_CACHE_VAL([hdf5_have_window_path], [hdf5_have_window_path=no])
-
-if test ${hdf5_have_window_path} = "yes"; then
- AC_DEFINE([HAVE_WINDOW_PATH], [1],
- [Define if your system has window style path name.])
- AC_MSG_RESULT([true])
-else
- AC_MSG_RESULT([false])
-fi
+case "`uname`" in
+ MINGW*)
+ AC_DEFINE([HAVE_WINDOW_PATH], [1],
+ [Define if your system has window style path name.])
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ AC_MSG_RESULT([no])
+ ;;
+esac
dnl -----------------------------------------------------------------------
dnl Set flag to indicate that the machine can handle conversion from