summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in47
1 files changed, 24 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index ab884db..59d8ed0 100644
--- a/configure.in
+++ b/configure.in
@@ -86,6 +86,30 @@ case $host_os in
;;
esac
+AC_ARG_ENABLE(hsizet,
+ [ --disable-hsizet Datasets can normally be larger than memory
+ and/or files but some compilers are unable to
+ handle this (including versions of GCC before
+ 2.8.0). Disabling the feature causes dataset
+ sizes to be restricted to the size of core memory,
+ or 'size_t'.],
+ HSIZET=$enableval)
+
+AC_MSG_CHECKING(for sizeof hsize_t and hssize_t)
+
+AC_SUBST(HSIZET)
+case $HSIZET in
+ no|small)
+ AC_MSG_RESULT(small)
+ HSIZET=small
+ ;;
+ *)
+ AC_MSG_RESULT(large)
+ HSIZET=large
+ AC_DEFINE(HAVE_LARGE_HSIZET)
+ ;;
+esac
+
host_config="none"
for f in $host_cpu-$host_vendor-$host_os \
$host_cpu-$host_vendor-$host_os_novers \
@@ -467,29 +491,6 @@ cat >>confdefs.h <<\EOF
EOF
AC_CHECK_SIZEOF(off_t, 4)
-AC_ARG_ENABLE(hsizet,
- [ --disable-hsizet Datasets can normally be larger than memory
- and/or files but some compilers are unable to
- handle this (including versions of GCC before
- 2.8.0). Disabling the feature causes dataset
- sizes to be restricted to the size of core memory,
- or 'size_t'.],
- HSIZET=$enableval)
-
-AC_MSG_CHECKING(for sizeof hsize_t and hssize_t)
-AC_SUBST(HSIZET)
-case $HSIZET in
- no|small)
- AC_MSG_RESULT(small)
- HSIZET=small
- ;;
- *)
- AC_MSG_RESULT(large)
- HSIZET=large
- AC_DEFINE(HAVE_LARGE_HSIZET)
- ;;
-esac
-
dnl Checkpoint the cache
AC_CACHE_SAVE