summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6481875..41429f6 100644
--- a/configure.in
+++ b/configure.in
@@ -1306,6 +1306,7 @@ AC_C_BIGENDIAN
AC_CHECK_SIZEOF([char], [1])
AC_CHECK_SIZEOF([short], [2])
AC_CHECK_SIZEOF([int], [4])
+AC_CHECK_SIZEOF([unsigned], [4])
AC_CHECK_SIZEOF([long], [4])
AC_CHECK_SIZEOF([long long], [8])
AC_CHECK_SIZEOF([__int64], [8])
@@ -2477,6 +2478,19 @@ case "X-$enable_parallel" in
fi
dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Check for building on Cray if RUNPARALLEL is not yet set by checking
+ dnl for 'aprun' command (which is the parallel job launcher, like mpirun).
+ if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
+ dnl Find the path where aprun is located.
+ for path in `echo $PATH | ${TR} ":" " "`; do
+ if test -x $path/aprun; then
+ RUNPARALLEL="aprun -q -n \$\${NPROCS:=3}"
+ break;
+ fi
+ done
+ fi
+
+ dnl Set RUNPARALLEL to mpirun if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
RUNPARALLEL="mpirun -np \$\${NPROCS:=3}"
fi