summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 17 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index e3a4f5c..d5dccc3 100644
--- a/configure.in
+++ b/configure.in
@@ -44,8 +44,8 @@ dnl OS
dnl VENDOR
dnl CPU
dnl
-AC_MSG_CHECKING(for site config file)
-site_config="none"
+AC_MSG_CHECKING(for host config file)
+host_config="none"
for f in $host \
$host_vendor-$host_os \
$host_cpu-$host_os \
@@ -54,13 +54,13 @@ for f in $host \
$host_vendor \
$host_cpu ; do
if test -f config/$f; then
- site_config=config/$f
+ host_config=config/$f
break
fi
done
-AC_MSG_RESULT($site_config)
-if test $site_config != "none"; then
- . $site_config
+AC_MSG_RESULT($host_config)
+if test $host_config != "none"; then
+ . $host_config
fi
@@ -265,12 +265,17 @@ dnl ----------------------------------------------------------------------
dnl Enable tracing of the API
dnl
AC_MSG_CHECKING(for API tracing);
-AC_ARG_ENABLE(tracing,
- --enable-tracing Cause the library to trace all API calls,
- CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
- AC_MSG_RESULT(yes),
- CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
- AC_MSG_RESULT(no))
+AC_ARG_ENABLE(trace,
+ [--disable-trace Disable API tracing capability],
+ TRACE=$enableval)
+
+if test X = "X$TRACE" -o Xyes = "X$TRACE"; then
+ AC_MSG_RESULT(yes)
+ CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
+else
+ AC_MSG_RESULT(no)
+ CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
+fi
dnl ----------------------------------------------------------------------
dnl Check for parallel support