summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 14 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 2205f93..0573681 100644
--- a/configure.in
+++ b/configure.in
@@ -111,10 +111,17 @@ dnl that it actually does what it's supposed to do. Catch this early
dnl since configure relies upon tr heavily and there's no use continuing
dnl if it's broken.
dnl
+
+dnl If the TR variable is set, use it as tr.
+AC_SUBST([TR])
+if test "X${TR}" = "X"; then
+ TR=tr
+fi
+
AC_MSG_CHECKING([if tr works])
-TR_TEST="`echo Test | tr 'a-z,' 'A-Z '`"
-if test $TR_TEST != "TEST"; then
- AC_MSG_ERROR([tr program doesn't work])
+TR_TEST="`echo Test | ${TR} 'a-z,' 'A-Z '`"
+if test "X${TR_TEST}" != "XTEST"; then
+ AC_MSG_ERROR([tr program ${TR} doesn't work])
else
AC_MSG_RESULT([yes])
fi
@@ -1815,7 +1822,7 @@ case "X-$DEBUG_PKG" in
esac
if test -n "$DEBUG_PKG"; then
- for pkg in `echo $DEBUG_PKG | tr 'a-z,' 'A-Z '`; do
+ for pkg in `echo $DEBUG_PKG | ${TR} 'a-z,' 'A-Z '`; do
CPPFLAGS="$CPPFLAGS -DH5${pkg}_DEBUG"
done
fi
@@ -1982,7 +1989,7 @@ case "$CC_BASENAME" in
if (echo $cmd | grep / >/dev/null); then
path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH | tr : ' '`; do
+ for path in `echo $PATH | ${TR} : ' '`; do
if test -x $path/$cmd; then
break
fi
@@ -2013,7 +2020,7 @@ case "$CC_BASENAME" in
if (echo $cmd | grep / >/dev/null); then
path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH | tr : ' '`; do
+ for path in `echo $PATH | ${TR} : ' '`; do
if test -x $path/$cmd; then
break
fi
@@ -2442,7 +2449,7 @@ case "X-$FILTERS" in
esac
if test -n "$FILTERS"; then
- for filter in `echo $FILTERS | tr 'a-z,' 'A-Z '`; do
+ for filter in `echo $FILTERS | ${TR} 'a-z,' 'A-Z '`; do
dnl ------------------------------------------------------------------
dnl Have to use separate 'if' construct for each filter, so that
dnl autoheader can detect the AC_DEFINE for each one...