summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fced9da..0e1640b 100644
--- a/configure.in
+++ b/configure.in
@@ -1725,6 +1725,42 @@ dnl
fi
dnl ----------------------------------------------------------------------
+dnl Do we want MPE instrumentation feature on?
+dnl This must be done after enable-parallel is checked since it depends on
+dnl a mpich compiler.
+dnl
+AC_SUBST(MPE) MPE=yes
+AC_ARG_ENABLE([mpe],
+ [AC_HELP_STRING([--enable-mpe],
+ [Enable MPE instrumentation [default=no]])],,
+ enableval=no)
+
+AC_MSG_CHECKING([for MPE instrumentation])
+case "X-$enableval" in
+ X-|X-no|X-none)
+ AC_MSG_RESULT(no)
+ unset MPE
+ ;;
+
+ X-yes)
+ AC_MSG_RESULT(yes)
+
+ dnl Check if MPE library is available
+ AC_CHECK_LIB(mpe,main,, unset MPE)
+ ;;
+
+ *)
+ AC_MSG_RESULT(error)
+ AC_MSG_ERROR(\'$enableval\' is not a valid MPE value)
+ unset MPE
+ ;;
+esac
+
+if test "X-$MPE" = "X-yes"; then
+ AC_DEFINE(HAVE_MPE, 1, [Define if we have MPE support])
+fi
+
+dnl ----------------------------------------------------------------------
dnl Turn on internal I/O filters by setting macros in header files
dnl Internal I/O filters are contained entirely within the library and do
dnl not depend on external headers or libraries. The shuffle filter is
@@ -2148,6 +2184,9 @@ esac
PRINT_N " Linux Large File Support (LFS)"
IF_ENABLED_DISABLED "$LINUX_LFS"
+PRINT_N " MPE"
+IF_YES_NO "$MPE"
+
PRINT_N " Pablo"
IF_YES_NO "$HAVE_PABLO"