summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 502bc8d..97f5ebb 100644
--- a/configure.in
+++ b/configure.in
@@ -976,8 +976,9 @@ case "$withval" in
if test `uname` != "FreeBSD"; then
AC_CHECK_LIB(pthread, pthread_create,,unset PTHREAD)
else
- CFLAGS="$CFLAGS -D_THREAD_SAFE"
+ CFLAGS="$CFLAGS -pthread -D_THREAD_SAFE"
LDFLAGS="$LDFLAGS -pthread"
+ LIBS="$LIBS -lcipher"
fi
;;
no)