summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ff618c7..ab0437d 100644
--- a/configure.in
+++ b/configure.in
@@ -742,6 +742,12 @@ dnl HP F90 v2.4
dnl Intel Fortran Compiler 8.1
dnl If any of these compilers is being used, disable shared libraries for
dnl Fortran.
+
+dnl Disable shared libraries in Fortran by default (sometimes libtool will
+dnl try to link against other shared libraries even though HDF5 is built
+dnl as a static library).
+H5_FORTRAN_SHARED="no"
+
if test "X${HDF_FORTRAN}" = "Xyes" && test "X${enable_shared}" != "Xno"; then
H5_FORTRAN_SHARED="yes"