summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index b5cf493..d424192 100644
--- a/configure.in
+++ b/configure.in
@@ -1833,12 +1833,23 @@ PRINT() {
echo "$1" 1>>src/libhdf5.settings
}
+dnl ----------------------------------------------------------------------
+dnl Print "Yes" if all arguments are "yes", otherwise "No"
+dnl
IF_YES_NO() {
- if test "$1" = "yes"; then
- PRINT "Yes"
- else
+ if test $# -lt 1; then
PRINT "No"
+ return
+ else
+ while test $# -gt 0; do
+ if test "$1" != "yes"; then
+ PRINT "No"
+ return
+ fi
+ shift
+ done
fi
+ PRINT "Yes"
}
IF_ENABLED_DISABLED() {
@@ -1928,5 +1939,6 @@ IF_ENABLED_DISABLED "$STREAM_VFD"
PRINT_N " Threadsafety"
IF_ENABLED_DISABLED "$THREADSAFE"
+dnl Zlib compression depends on zlib.h header and compress2()
PRINT_N " Zlib-compression"
-IF_YES_NO "$HAVE_ZLIB"
+IF_YES_NO "$ac_cv_header_zlib_h" "$ac_cv_func_compress2"