summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4c49a72..ef7fe9d 100644
--- a/configure.in
+++ b/configure.in
@@ -742,8 +742,11 @@ AC_CHECK_HEADERS([stddef.h setjmp.h features.h])
AC_CHECK_HEADERS([stdint.h], [C9x=yes])
dnl Windows
-AC_CHECK_HEADERS([io.h winsock.h sys/timeb.h])
-
+if test "`uname -o`" = "Cygwin"; then
+ AC_CHECK_HEADERS([io.h sys/timeb.h])
+else
+ AC_CHECK_HEADERS([io.h winsock.h sys/timeb.h])
+fi
case "$host" in
alpha*-dec*-osf*)
dnl The <sys/sysinfo.h> and <sys/proc.h> are needed on the DEC