summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 18 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index c456eca..252d5e3 100644
--- a/configure.in
+++ b/configure.in
@@ -1635,23 +1635,24 @@ dnl If gettimeofday() is going to be used, make sure it uses the timezone struct
if test "$have_gettime" = "yes" -a "$have_struct_tz" = "yes"; then
AC_MSG_CHECKING(whether gettimeofday() gives timezone)
- AC_TRY_RUN([
- #include <time.h>
- #include <sys/time.h>
- int main(void)
- {
- struct timeval tv;
- struct timezone tz;
- tz.tz_minuteswest = 7777; /* Initialize to an unreasonable number */
- tz.tz_dsttime = 7;
- gettimeofday(&tv, &tz);
- /* Check whether the function returned any value at all */
- if(tz.tz_minuteswest == 7777 && tz.tz_dsttime == 7)
- exit(1);
- else exit (0);
- }], [hdf5_use_tz="yes"], [hdf5_use_tz="no"],)
-
- if test "$hdf5_use_tz" = "yes"; then
+ AC_CACHE_VAL([hdf5_cv_gettimeofday_tz],
+ [AC_TRY_RUN([
+ #include <time.h>
+ #include <sys/time.h>
+ int main(void)
+ {
+ struct timeval tv;
+ struct timezone tz;
+ tz.tz_minuteswest = 7777; /* Initialize to an unreasonable number */
+ tz.tz_dsttime = 7;
+ gettimeofday(&tv, &tz);
+ /* Check whether the function returned any value at all */
+ if(tz.tz_minuteswest == 7777 && tz.tz_dsttime == 7)
+ exit(1);
+ else exit (0);
+ }], [hdf5_cv_gettimeofday_tz=yes], [hdf5_cv_gettimeofday_tz=no],)])
+
+ if test ${hdf5_cv_gettimeofday_tz} = "yes"; then
AC_MSG_RESULT([yes])
AC_DEFINE([GETTIMEOFDAY_GIVES_TZ], [1],
[Define if gettimeofday() populates the tz pointer passed in])