summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d8dbb14..dc9efc2 100644
--- a/configure.in
+++ b/configure.in
@@ -991,7 +991,7 @@ AC_ARG_ENABLE(production,
[Determines how to run the compiler.])])
case "X-$enable_production" in
- X-|X-yes)
+ X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
@@ -1033,7 +1033,7 @@ case "X-$enable_production" in
H5_CXXFLAGS="$H5_CXXFLAGS $PROD_CXXFLAGS"
H5_FCFLAGS="$H5_FCFLAGS $PROD_FCFLAGS"
;;
- X-no)
+ X-|X-no)
enable_production="no"
AC_MSG_RESULT([development])
CONFIG_MODE=development
@@ -2041,7 +2041,7 @@ AC_ARG_ENABLE([debug],
AC_SUBST([DEBUG_PKG])
all_packages="ac,b,b2,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
- X-yes)
+ X-|X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
H5_CPPFLAGS="$H5_CPPFLAGS -UNDEBUG"
AC_MSG_RESULT([default ($DEBUG_PKG)])
@@ -2051,7 +2051,7 @@ case "X-$DEBUG_PKG" in
H5_CPPFLAGS="$H5_CPPFLAGS -UNDEBUG"
AC_MSG_RESULT([all ($DEBUG_PKG)])
;;
- X-|X-no|X-none)
+ X-no|X-none)
AC_MSG_RESULT([none])
DEBUG_PKG=
H5_CPPFLAGS="$H5_CPPFLAGS -DNDEBUG"