summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index a805593..0512054 100644
--- a/configure.in
+++ b/configure.in
@@ -444,22 +444,6 @@ int main(void) {
CXXFLAGS="${CXXFLAGS} -DBOOL_NOTDEFINED"
])
- AC_CONFIG_HEADER([c++/src/H5cxx_config.h])
-
- AC_OUTPUT_COMMANDS([
- echo "creating c++/src/H5cxx_pubconf.h"
- sed 's/#define /#define H5_CXX_/' <c++/src/H5cxx_config.h |\
- sed 's/#undef /#undef H5_CXX_/' >pubconf
- if test ! -f c++/src/H5cxx_pubconf.h; then
- /bin/mv -f pubconf c++/src/H5cxx_pubconf.h
- elif (diff pubconf c++/src/H5cxx_pubconf.h >/dev/null); then
- rm -f pubconf
- echo "c++/src/H5cxx_pubconf.h is unchanged"
- else
- /bin/mv -f pubconf c++/src/H5cxx_pubconf.h
- fi
- ])
-
AC_MSG_CHECKING([if $CXX has offsetof extension])
AC_TRY_COMPILE([
#include <stdio.h>
@@ -476,7 +460,7 @@ int main(void) {
x = offsetof(struct index_st, len);
y = offsetof(index_t, num)
],
- AC_DEFINE([HAVE_OFFSETOF], [1],
+ AC_DEFINE([CXX_HAVE_OFFSETOF], [1],
[Define if C++ compiler recognizes offsetof])
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no]))