summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 893a779..d16aebe 100644
--- a/configure.in
+++ b/configure.in
@@ -2534,6 +2534,23 @@ else
AC_MSG_RESULT([no])
fi
+dnl ----------------------------------------------------------------------
+dnl Set the flag to indicate that the machine can handle converting
+dnl floating-point to long long values.
+dnl (This flag should be _unset_ for all machines, except for Windows, where
+dnl it's set in the custom Windows H5pubconf.h file)
+dnl
+AC_MSG_CHECKING([if converting floating-point values to long long is not working])
+AC_CACHE_VAL([hdf5_cv_convert_float_llong_not_works], [hdf5_cv_convert_float_llong_not_works=yes])
+
+if test ${hdf5_cv_convert_float_llong_not_works} = "yes"; then
+ AC_DEFINE([HW_FP_TO_LLONG_NOT_WORKS], [1],
+ [Define if your system can't handle converting floating-point values to long long.])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl -----------------------------------------------------------------------
dnl Set flag to indicate that the machine can handle conversion from
dnl long double to integers accurately. This flag should be set "yes" for