summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in52
1 files changed, 30 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 83d4762..ac43690 100644
--- a/configure.in
+++ b/configure.in
@@ -1318,28 +1318,6 @@ if test "X$THREADSAFE" = "Xyes"; then
fi
dnl ----------------------------------------------------------------------
-dnl Check if they would like the function stack support compiled in
-dnl
-AC_MSG_CHECKING([whether function stack tracking is enabled])
-AC_ARG_ENABLE([funcstack],
- [AC_HELP_STRING([--enable-funcstack],
- [Enable the function stack
- tracing [default=yes]])],
- [FUNCSTACK=$enableval])
-
-case "X-$FUNCSTACK" in
- X-|X-yes)
- FUNCSTACK="yes"
- AC_MSG_RESULT([yes])
- AC_DEFINE([HAVE_FUNCSTACK], [1],
- [Define if the function stack tracing code is to be compiled in])
- ;;
- *)
- AC_MSG_RESULT([no])
- ;;
-esac
-
-dnl ----------------------------------------------------------------------
dnl Check if they would like the HDF5 v1.4 compatibility functions
dnl compiled in
dnl
@@ -1679,6 +1657,36 @@ if test -n "$DEBUG_PKG"; then
fi
dnl ----------------------------------------------------------------------
+dnl Check if they would like the function stack support compiled in
+dnl
+AC_MSG_CHECKING([whether function stack tracking is enabled])
+AC_ARG_ENABLE([funcstack],
+ [AC_HELP_STRING([--enable-funcstack],
+ [Enable the function stack tracing.
+ Default=no if debug is disabled.])],
+ [FUNCSTACK=$enableval])
+
+dnl Default to no if debug is disabled
+if test "X-$FUNCSTACK" = X- ; then
+ if test -z "$DEBUG_PKG" ; then
+ FUNCSTACK=no
+ else
+ FUNCSTACK=yes
+ fi
+fi
+case "X-$FUNCSTACK" in
+ X-|X-yes)
+ FUNCSTACK="yes"
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_FUNCSTACK], [1],
+ [Define if the function stack tracing code is to be compiled in])
+ ;;
+ *)
+ AC_MSG_RESULT([no])
+ ;;
+esac
+
+dnl ----------------------------------------------------------------------
dnl Enable tracing of the API
dnl This must come after the enable-debug since it depends on debug.
dnl