summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index af929fe..8d689e0 100644
--- a/configure.in
+++ b/configure.in
@@ -1224,6 +1224,28 @@ if test "X$THREADSAFE" = "Xyes"; then
fi
dnl ----------------------------------------------------------------------
+dnl Check if they would like the function stack support compiled in
+dnl
+AC_MSG_CHECKING([whether function stack tracking is enabled])
+AC_ARG_ENABLE([funcstack],
+ [AC_HELP_STRING([--enable-funcstack],
+ [Enable the function stack
+ tracing [default=yes]])],
+ [FUNCSTACK=$enableval])
+
+case "X-$FUNCSTACK" in
+ X-|X-yes)
+ FUNCSTACK="yes"
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_FUNCSTACK], [1],
+ [Define if the function stack tracing code is to be compiled in])
+ ;;
+ *)
+ AC_MSG_RESULT([no])
+ ;;
+esac
+
+dnl ----------------------------------------------------------------------
dnl Check if they would like the HDF5 v1.4 compatibility functions
dnl compiled in
dnl
@@ -2302,5 +2324,8 @@ IF_ENABLED_DISABLED "$STREAM_VFD"
PRINT_N " Threadsafety"
IF_ENABLED_DISABLED "$THREADSAFE"
+PRINT_N " Function Stack Tracing"
+IF_ENABLED_DISABLED "$FUNCSTACK"
+
PRINT_N " Zlib-compression"
IF_YES_NO "$HAVE_ZLIB"