summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 296c955..d4dbf41 100644
--- a/configure.in
+++ b/configure.in
@@ -65,7 +65,7 @@ dnl Different compilers may need default libraries. They are specified in
dnl the config/* files, so we put this statement here so that it'll be
dnl set by the code which follows...
dnl
-AC_SUBST(DEFAULT_LIBS) DEFAULT_LIBS=""
+DEFAULT_LIBS=""
dnl ----------------------------------------------------------------------
dnl Set prefix default (install directory) to a directory in the build area.
@@ -2895,6 +2895,11 @@ fi
AC_SUBST([ROOT]) ROOT="`$pwd`"
dnl ----------------------------------------------------------------------
+dnl Move any compiler-specific libraries into the main LIBS varaible.
+dnl
+LIBS="$DEFAULT_LIBS $LIBS"
+
+dnl ----------------------------------------------------------------------
dnl Determine the runtime libraries we may need to include in the
dnl libtools command so that executables will find the correct dynamic
dnl libraries.