summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 28 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 56fb28b..841d25d 100644
--- a/configure.in
+++ b/configure.in
@@ -761,7 +761,7 @@ dnl If the library path is specified then it must be preceded by a comma.
dnl
AC_ARG_WITH([zlib],
[AC_HELP_STRING([--with-zlib=DIR],
- [Use GNU zlib compression [default=yes]])],,
+ [Use zlib library for external deflate I/O filter [default=yes]])],,
withval=yes)
case $withval in
@@ -830,8 +830,14 @@ case $withval in
esac
if test "x$HAVE_ZLIB" = "xyes" -a "x$HAVE_ZLIB_H" = "xyes" -a "x$HAVE_COMPRESS2" = "xyes"; then
- AC_DEFINE(HAVE_FILTER_DEFLATE, 1,
+ AC_DEFINE(HAVE_FILTER_DEFLATE, 1,
[Define if support for deflate filter is enabled])
+
+ dnl Add "deflate" to external filter list
+ if test "X$EXTERNAL_FILTERS" != "X"; then
+ EXTERNAL_FILTERS="${EXTERNAL_FILTERS},"
+ fi
+ EXTERNAL_FILTERS="${EXTERNAL_FILTERS}deflate"
fi
@@ -843,7 +849,7 @@ dnl If the library path is specified then it must be preceded by a comma.
dnl
AC_ARG_WITH([szlib],
[AC_HELP_STRING([--with-szlib=DIR],
- [Use szlib compression [default=yes]])],,
+ [Use szlib library for external szlib I/O filter [default=yes]])],,
withval=yes)
case $withval in
@@ -851,8 +857,6 @@ case $withval in
HAVE_SZLIB="yes"
AC_CHECK_HEADERS([szlib.h], [HAVE_SZLIB_H="yes"])
AC_CHECK_LIB([sz], [SZ_BufftoBuffCompress],, [unset HAVE_SZLIB])
- dnl Not including this function checking for the time being
- dnl AC_CHECK_FUNC([compress2], [HAVE_COMPRESS2="yes"])
if test -z "$HAVE_SZLIB" -a -n "$HDF5_CONFIG_ABORT"; then
AC_MSG_ERROR([couldn't find szlib library])
@@ -904,7 +908,6 @@ case $withval in
AC_CHECK_LIB([sz], [SZ_BufftoBuffCompress],,
[LDFLAGS="$saved_LDFLAGS"; unset HAVE_SZLIB])
-dnl AC_CHECK_FUNC([compress2], [HAVE_COMPRESS2="yes"])
if test -z "$HAVE_SZLIB" -a -n "$HDF5_CONFIG_ABORT"; then
AC_MSG_ERROR([couldn't find szlib library])
@@ -912,12 +915,15 @@ dnl AC_CHECK_FUNC([compress2], [HAVE_COMPRESS2="yes"])
;;
esac
-dnl if test "x$HAVE_ZLIB" = "xyes" -a "x$HAVE_ZLIB_H" = "xyes" -a "x$HAVE_COMPRESS2" = "xyes"; then
-
- if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
-
- AC_DEFINE(HAVE_FILTER_SZIP, 1,
+if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
+ AC_DEFINE(HAVE_FILTER_SZIP, 1,
[Define if support for szip filter is enabled])
+
+ dnl Add "szip" to external filter list
+ if test "X$EXTERNAL_FILTERS" != "X"; then
+ EXTERNAL_FILTERS="${EXTERNAL_FILTERS},"
+ fi
+ EXTERNAL_FILTERS="${EXTERNAL_FILTERS}szip"
fi
dnl ----------------------------------------------------------------------
@@ -2308,6 +2314,11 @@ if test -z "$ECHO_N" -o -z "$ECHO_C"; then
fi
fi
+PRINT_PLAIN() {
+ echo $ECHO_N "$1$ECHO_C"
+ echo $ECHO_N "$1$ECHO_C" 1>>src/libhdf5.settings
+}
+
PRINT_N() {
echo $ECHO_N "$1: $ECHO_C"
echo $ECHO_N "$1: $ECHO_C" 1>>src/libhdf5.settings
@@ -2415,15 +2426,18 @@ IF_YES_NO "$GPFS"
PRINT_N " HDF5 v1.4 Compatibility"
IF_YES_NO "$HDF5_V1_4_COMPAT"
-PRINT_N " Internal I/O filters"
-PRINT "$FILTERS"
-
PRINT_N " hsize_t"
case "$HSIZET" in
no|small) PRINT "Small" ;;
*) PRINT "Large" ;;
esac
+PRINT_N " I/O filters (external)"
+PRINT "$EXTERNAL_FILTERS"
+
+PRINT_N " I/O filters (internal)"
+PRINT "$FILTERS"
+
PRINT_N " Linux Large File Support (LFS)"
IF_ENABLED_DISABLED "$LINUX_LFS"
@@ -2448,9 +2462,3 @@ IF_ENABLED_DISABLED "$STREAM_VFD"
PRINT_N " Threadsafety"
IF_ENABLED_DISABLED "$THREADSAFE"
-
-PRINT_N " Zlib-compression"
-IF_YES_NO "$HAVE_ZLIB"
-
-PRINT_N " SZlib-compression"
-IF_YES_NO "$HAVE_SZLIB"