summaryrefslogtreecommitdiffstats
path: root/fortran/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/CMakeLists.txt')
-rw-r--r--fortran/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/fortran/CMakeLists.txt b/fortran/CMakeLists.txt
index 31edad2..9755963 100644
--- a/fortran/CMakeLists.txt
+++ b/fortran/CMakeLists.txt
@@ -23,8 +23,11 @@ endif ()
# Testing
#-----------------------------------------------------------------------------
if (BUILD_TESTING)
- add_subdirectory (test)
- if (MPI_Fortran_FOUND)
- add_subdirectory (testpar)
+ if (HDF5_TEST_SERIAL)
+ add_subdirectory (test)
+ endif ()
+ if (MPI_Fortran_FOUND AND HDF5_TEST_PARALLEL)
+ add_subdirectory (testpar)
+ endif ()
endif ()
endif ()