summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 618094e..e2c98b9 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -214,6 +214,23 @@ EOF
fi
dnl ----------------------------------------------------------------------
+dnl If we should build only static executables
+dnl
+AC_MSG_CHECKING(if should build only statically linked executables)
+AC_ARG_ENABLE(static_exec,
+ [ --enable-static-exec Build only statically linked executables [default=no]],
+ STATIC_EXEC=$enableval)
+
+if test "X$STATIC_EXEC" = "Xyes"; then
+ echo "yes"
+ LT_STATIC_EXEC="-all-static"
+else
+ echo "no"
+ LT_STATIC_EXEC=""
+fi
+AC_SUBST(LT_STATIC_EXEC)
+
+dnl ----------------------------------------------------------------------
dnl Check for a Fortran 9X compiler, how to optimize it, and how to
dnl include modules.
dnl