summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index c367674..618094e 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -537,15 +537,19 @@ dnl
DYNAMIC_DIRS=""
if test -n "$LDFLAGS"; then
for d in $LDFLAGS ; do
- d=`echo $d | sed -e 's/-L//g'`
case "$d" in
- .*)
- dnl If the path isn't absolute, make it so by prepending the
- dnl ROOT directory to it.
- d=${ROOT}/$d
+ -L*)
+ d=`echo $d | sed -e 's/-L//g'`
+ case "$d" in
+ .*)
+ dnl If the path isn't absolute, make it so by prepending the
+ dnl ROOT directory to it.
+ d=${ROOT}/$d
+ ;;
+ esac
+ DYNAMIC_DIRS="-R${d} $DYNAMIC_DIRS"
;;
esac
- DYNAMIC_DIRS="-R${d} $DYNAMIC_DIRS"
done
fi
AC_SUBST(DYNAMIC_DIRS)