summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 5463d99..1b6bf45 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -137,6 +137,15 @@ AC_PROG_MAKE_SET
AC_PROG_INSTALL
AM_PROG_LIBTOOL
+dnl ----------------------------------------------------------------------
+dnl Check if they have Perl installed on their system. We only need Perl
+dnl if they're using a GNU compiler.
+dnl
+AC_SUBST(PERL) PERL=""
+if test "X$GCC" = "Xyes"; then
+ AC_CHECK_PROGS(PERL, perl,, $PATH)
+fi
+
if test -z "$AR"; then
AC_CHECK_PROGS(AR,ar xar,:,$PATH)
fi