summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index dd7bcd4..a27db47 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -552,7 +552,7 @@ if test -n "$PARALLEL"; then
AC_TRY_LINK([
#include <mpi.h>
],
- [MPI_Comm_c2f()],
+ [MPI_Comm c_comm; MPI_Comm_c2f(c_comm)],
AC_DEFINE(HAVE_MPI_MULTI_LANG_Comm, 1,
[Define if \`MPI_Comm_c2f' and \`MPI_Comm_f2c' exists])
AC_MSG_RESULT(yes),
@@ -563,7 +563,7 @@ if test -n "$PARALLEL"; then
AC_TRY_LINK([
#include <mpi.h>
],
- [MPI_Info_c2f()],
+ [MPI_Info c_info; MPI_Info_c2f(c_info)],
AC_DEFINE(HAVE_MPI_MULTI_LANG_Info, 1,
[Define if \`MPI_Info_c2f' and \`MPI_Info_f2c' exists])
AC_MSG_RESULT(yes),