summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 404b356..25a01b8 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -957,6 +957,28 @@ EOF
rm makeinc maketest
fi
+dnl ----------------------------------------------------------------------
+dnl Checking to see if GPFS is available on this filesystem
+dnl
+
+dnl Change to the C language
+AC_LANG_C
+
+AC_CHECK_HEADERS([gpfs.h],
+ AC_MSG_CHECKING([for GPFS support])
+ AC_TRY_COMPILE([#include <gpfs.h>],
+ [int fd = 0; gpfs_fcntl(fd, (void *)0);],
+ AC_DEFINE(HAVE_GPFS, 1,
+ [Define if we have GPFS support])
+ AC_MSG_RESULT(yes)
+ LIBS="$LIBS -lgpfs"
+ GPFS="yes",
+ AC_MSG_RESULT(no)
+ GPFS="no"))
+
+dnl Change back to the Fortran 90 language
+AC_LANG_FORTRAN9X
+
dnl Some cleanup stuff
rm -f conftest core core.* *.core conftest.o conftest.c dummy.o $ac_clean_files