summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in26
1 files changed, 10 insertions, 16 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 82098b5..106bcf1 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -360,10 +360,10 @@ dnl protect the expansion until make executes the
dnl command). The value of this variable is
dnl substituted in *.in files.
dnl
-AC_SUBST(PARALLEL)
-AC_SUBST(RUNSERIAL)
-AC_SUBST(RUNPARALLEL)
-AC_SUBST(TESTPARALLEL)
+AC_SUBST(PARALLEL) PARALLEL=""
+AC_SUBST(RUNSERIAL) RUNSERIAL=""
+AC_SUBST(RUNPARALLEL) RUNPARALLEL=""
+AC_SUBST(TESTPARALLEL) TESTPARALLEL=""
dnl ----------------------------------------------------------------------
dnl If the compiler is obviously a parallel compiler then we're building
@@ -443,23 +443,19 @@ case "X-$enable_parallel" in
dnl Try link a simple MPI program. If fail, try again with -lmpi.
AC_TRY_FLINK(mpif.h, [
- integer ierr
- call MPI_INIT( ierr )],,
+ call mpi_file_open( ierr )],,
AC_CHECK_FLIB(mpi, [
include 'mpif.h'
- integer ierr
- call MPI_INIT( ierr )],, PARALLEL=no))
+ call mpi_file_open( ierr )],, PARALLEL=no))
dnl Then try link a simple MPI-IO program. If fail, try again with
dnl -lmpio.
if test "X$PARALLEL" = "Xyes"; then
AC_TRY_FLINK(mpif.h, [
- integer ierr
- call MPI_INIT( ierr )],
+ call mpi_file_open( ierr )],,
AC_CHECK_FLIB(mpio, [
include 'mpif.h'
- integer ierr
- call MPI_INIT( ierr )],, PARALLEL=no))
+ call mpi_file_open( ierr )],, PARALLEL=no))
fi
dnl Set RUNPARALLEL to mpirun if not set yet.
@@ -484,8 +480,7 @@ case "X-$enable_parallel" in
PARALLEL=mpich
AC_CHECK_FLIB(fmpich, [
include 'mpif.h'
- integer ierr
- call MPI_INIT( ierr )],, AC_MSG_ERROR(no mpich library))
+ call mpi_file_open( ierr )],, AC_MSG_ERROR(no mpich library))
;;
*)
@@ -515,8 +510,7 @@ if test -n "$PARALLEL"; then
dnl Check that we can link a simple MPI and MPI-IO application
AC_MSG_CHECKING(whether a simple MPI-IO program can be linked)
AC_TRY_FLINK(mpif.h,[
- integer ierr
- call MPI_INIT( ierr )],
+ call mpi_file_open( ierr )],
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no)
AC_MSG_ERROR('unable to link a simple MPI-IO application'))