summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index e894841..8385b03 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -407,6 +407,18 @@ AC_CACHE_SAVE
dnl Change back to the Fortran 90 language
AC_LANG_FORTRAN9X
+dnl See if the compiler will support the "-I." option
+FFLAGS_saved=$FFLAGS
+FFLAGS="$FFLAGS -I."
+
+AC_MSG_CHECKING(if compiler supports -I. option)
+AC_TRY_FCOMPILE([
+ program conftest
+ end
+], AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+ FFLAGS="$FFLAGS_saved")
+
dnl ----------------------------------------------------------------------
dnl The following variables are used to distinguish between building a
dnl serial and parallel library.