summaryrefslogtreecommitdiffstats
path: root/fortran/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/examples/Makefile.am')
-rw-r--r--fortran/examples/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/fortran/examples/Makefile.am b/fortran/examples/Makefile.am
index 1d258c7..3200f63 100644
--- a/fortran/examples/Makefile.am
+++ b/fortran/examples/Makefile.am
@@ -53,10 +53,11 @@ attrexample.chkexe_: rwdsetexample.chkexe_
# Tell automake how to build examples using h5fc
# Additional dependencies for the examples are listed below
-$(EXTRA_PROG): $(LIBHDF5) $(LIBH5F)
if BUILD_PARALLEL_CONDITIONAL
+$(EXTRA_PROG): $(H5FC_PP)
$(H5FC_PP) $(FCFLAGS) -o $@ $(srcdir)/$@.f90;
else
+$(EXTRA_PROG): $(H5FC)
$(H5FC) $(FCFLAGS) -o $@ $(srcdir)/$@.f90;
endif