summaryrefslogtreecommitdiffstats
path: root/fortran/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/examples/Makefile.am')
-rw-r--r--fortran/examples/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/fortran/examples/Makefile.am b/fortran/examples/Makefile.am
index 92dabfb..88d1c98 100644
--- a/fortran/examples/Makefile.am
+++ b/fortran/examples/Makefile.am
@@ -51,9 +51,12 @@ CLEANFILES=*.h5 $(EXTRA_PROG)
HDF_FORTRAN=yes
# Some examples depend on files created by other examples.
-rwdsetexample.chkexe_ attrexample.chkexe_: dsetexample.chkexe_
grpdsetexample.chkexe_: grpsexample.chkexe_
refregexample.chkexe_: refobjexample.chkexe_
+# rwdsetexample and attrexample both modify the same file created by
+# dsetexample. Serialize them.
+rwdsetexample.chkexe_: dsetexample.chkexe_
+attrexample.chkexe_: rwdsetexample.chkexe_
# Tell automake how to build examples using h5fc
# Additional dependencies for the examples are listed below