summaryrefslogtreecommitdiffstats
path: root/fortran/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/examples/Makefile.am')
-rw-r--r--fortran/examples/Makefile.am36
1 files changed, 1 insertions, 35 deletions
diff --git a/fortran/examples/Makefile.am b/fortran/examples/Makefile.am
index 389d15d..1d258c7 100644
--- a/fortran/examples/Makefile.am
+++ b/fortran/examples/Makefile.am
@@ -34,20 +34,12 @@ TEST_PROG=dsetexample fileexample rwdsetexample attrexample groupexample \
grpsexample grpdsetexample hyperslab selectele grpit refobjexample \
refregexample mountexample compound
-# Tell configure.in when to build examples
-EXTRA_PROG=$(TEST_PROG) $(TEST_PROG_PARA)
-EXAMPLE_PROG=$(EXTRA_PROG)
-
# List files to be installed here
INSTALL_FILES=dsetexample.f90 fileexample.f90 rwdsetexample.f90 \
attrexample.f90 groupexample.f90 grpsexample.f90 grpdsetexample.f90 \
hyperslab.f90 selectele.f90 grpit.f90 refobjexample.f90 \
refregexample.f90 mountexample.f90 compound.f90 ph5example.f90
-# Tell automake which files to clean
-MOSTLYCLEANFILES=$(EXTRA_PROG:=.o)
-CLEANFILES=*.h5 $(EXTRA_PROG)
-
# Mark this directory as part of the Fortran API
HDF_FORTRAN=yes
@@ -71,33 +63,6 @@ endif
# Tell automake how to install examples
EXAMPLEDIR=$(docdir)/hdf5/examples/fortran
-$(EXAMPLEDIR):
- -$(top_srcdir)/bin/mkdirs $@
-
-install-data-local:
- @$(MAKE) install-examples
-uninstall-local:
- @$(MAKE) uninstall-examples
-
-# We're installing source files, not the example programs. Add .f90 to each
-# example program to get its source (and do the same when uninstalling).
-install-examples: $(EXAMPLEDIR)
- @for f in X $(INSTALL_FILES); do \
- if test $$f != X; then \
- (set -x; $(INSTALL_DATA) $(top_srcdir)/fortran/examples/$$f $(EXAMPLEDIR)/. || exit 1);\
- fi; \
- done
-
-uninstall-examples:
- @if test -n "$(INSTALL_FILES)" -a -d $(EXAMPLEDIR); then \
- set -x; cd $(EXAMPLEDIR) && $(RM) $(EXAMPLE_PROG); \
- fi
-
-check-install:
- @$(MAKE) installcheck
-installcheck-local:
- @$(MAKE) check
-
# List dependencies for each example. Normally, automake would take
# care of this for us, but if we tell automake about the programs it
# will try to build them with the normal C compiler, not h5cc. This is
@@ -120,4 +85,5 @@ mountexample: mountexample.f90
compound: compound.f90
ph5example: ph5example.f90
+include $(top_srcdir)/config/examples.am
include $(top_srcdir)/config/conclude.am