summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index d2644a1..f38e94f 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -90,11 +90,14 @@ clean-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
$(RM) *.$(F9XMODEXT); \
fi
+ $(RM) $(DESTDIR)$(includedir)/H5f90i*.h
install-data-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
$(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
fi
+ $(CP) $(top_builddir)/$(subdir)/H5f90i_gen.h $(DESTDIR)$(includedir)/.
+ $(CP) $(top_srcdir)/fortran/src/H5f90i.h $(DESTDIR)$(includedir)/.
uninstall-local:
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
@@ -103,6 +106,7 @@ uninstall-local:
fi; \
fi; \
$(RM) $(DESTDIR)$(bindir)/$(H5FC_NAME)
+ $(RM) $(DESTDIR)$(includedir)/H5f90i*.h
# Also install and uninstall (uninstall-local above) h5fc script
install-exec-local: