summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 83e71e8..cc46d1c 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -20,9 +20,9 @@
include $(top_srcdir)/config/commence.am
# Include src directory in both Fortran and C flags (C compiler is used
-# for linking)
+# for linking).
INCLUDES = -I$(top_srcdir)/src
-AM_FCFLAGS=-I$(top_srcdir)/src
+AM_FCFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/src/fortran
AM_FCLIBS=$(LIBHDF5)
@@ -124,11 +124,6 @@ H5fortran_types.f90 H5f90i_gen.h: H5match_types.c H5fort_type_defines.h
$(MAKE) $(AM_MAKEFLAGS) H5match_types$(EXEEXT)
$(RUNSERIAL) ./H5match_types$(EXEEXT)
-
-# JAMES: does it need to work like this? $(MAKE) $(AM_MAKEFLAGS) H5fort_type_defines.h
-# JAMES $(MAKE) $(AM_MAKEFLAGS) H5match_types$(EXEEXT)
-# JAMES $(RUNSERIAL) ./H5match_types$(EXEEXT)
-
# H5fort_type_defines.h is created by running H5fortran_detect.
# Obviously, H5fortran_detect needs to be built first.
H5fort_type_defines.h: H5fortran_detect$(EXEEXT)