summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am23
1 files changed, 1 insertions, 22 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index ef6cd7e..9e03996 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -30,8 +30,6 @@ noinst_LTLIBRARIES=libh5test_fortran.la
# want to build a shared C library and a static Fortran library. If so,
# pass the -static flag to the library linker.
if FORTRAN_SHARED_CONDITIONAL
- TEST_SCRIPT = test_vol_connector.sh
- SCRIPT_DEPEND = vol_connector$(EXEEXT)
else
AM_LDFLAGS+=-static
endif
@@ -39,26 +37,9 @@ endif
check_SCRIPTS = $(TEST_SCRIPT)
# Our main targets, the tests themselves
-TEST_PROG=fortranlib_test fflush1 fflush2 fortranlib_test_1_8 fortranlib_test_F03
+TEST_PROG=fortranlib_test fflush1 fflush2 fortranlib_test_1_8 fortranlib_test_F03 vol_connector
check_PROGRAMS=$(TEST_PROG)
-if FORTRAN_SHARED_CONDITIONAL
- check_PROGRAMS+= vol_connector
-endif
-
-if FORTRAN_SHARED_CONDITIONAL
- # The libh5test library provides common support code for the tests.
- # The filter_plugin* libraries are for use in filter_plugin.c.
- # Build them as shared libraries if that option was enabled in configure.
- noinst_LTLIBRARIES += libnull_vol_connector.la
-
- # VOL plugin test libraries
- #
- # null_vol_connector is used for testing basic VOL plugin functionality.
- libnull_vol_connector_la_SOURCES=null_vol_connector.c
- libnull_vol_connector_la_LDFLAGS=$(AM_LDFLAGS) -avoid-version -module -shared -export-dynamic -rpath /nowhere
-endif
-
libh5test_fortran_la_SOURCES = tf_gen.F90 tf.F90 t.c
@@ -117,8 +98,6 @@ H5_test_buildiface_SOURCES = H5_test_buildiface.F90
H5_test_buildiface_LDADD =
-DISTCLEANFILES=test_vol_connector.sh # TODO:CHECK IF WORKS MSB
-
# fflush2 depends on files created by fflush1
fflush2.chkexe_: fflush1.chkexe_