summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 9a04106..735ab7a 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -60,7 +60,11 @@ else
libh5test_fortran_la_SOURCES = tf_F03.f90
endif
else
+if FORTRAN_2003_CONDITIONAL_F
libh5test_fortran_la_SOURCES = tf_F03.f90
+else
+ libh5test_fortran_la_SOURCES = tf_F90.f90
+endif
endif
# tf.f90 depends on either tf_F08.f90 or tf_F03.f90 so they need to be