summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 735ab7a..f8c9d02 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -53,23 +53,7 @@ endif
check_PROGRAMS=$(TEST_PROG)
-if FORTRAN_HAVE_STORAGE_SIZE
-if FORTRAN_HAVE_C_SIZEOF
- libh5test_fortran_la_SOURCES = tf_F08.f90
-else
- libh5test_fortran_la_SOURCES = tf_F03.f90
-endif
-else
-if FORTRAN_2003_CONDITIONAL_F
- libh5test_fortran_la_SOURCES = tf_F03.f90
-else
- libh5test_fortran_la_SOURCES = tf_F90.f90
-endif
-endif
-
-# tf.f90 depends on either tf_F08.f90 or tf_F03.f90 so they need to be
-# compiled first
-libh5test_fortran_la_SOURCES += tf.f90 t.c
+libh5test_fortran_la_SOURCES = tf.F90 t.c
# Source files are used for both the library and fortranlib_test.
# Automake will complain about this without the following workaround.