summaryrefslogtreecommitdiffstats
path: root/fortran/testpar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fortran/testpar/Makefile.am')
-rw-r--r--fortran/testpar/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/fortran/testpar/Makefile.am b/fortran/testpar/Makefile.am
index e6301d0..39aceb0 100644
--- a/fortran/testpar/Makefile.am
+++ b/fortran/testpar/Makefile.am
@@ -22,6 +22,9 @@ include $(top_srcdir)/config/commence.am
# Include files
AM_FFLAGS=-I$(top_srcdir)/fortran/src -I$(top_srcdir)/fortran/test $(F9XMODFLAG)$(top_builddir)/fortran/src
+# Fortran libraries are linked statically to solve a build problem.
+AM_LDFLAGS=-static
+
# These are our main targets
TEST_PROG_PARA=ptesthdf5_fortran
check_PROGRAMS=$(TEST_PROG_PARA)