summaryrefslogtreecommitdiffstats
path: root/hl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hl/CMakeLists.txt')
-rw-r--r--hl/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/hl/CMakeLists.txt b/hl/CMakeLists.txt
index bed8291..a47e023 100644
--- a/hl/CMakeLists.txt
+++ b/hl/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required (VERSION 3.1.0)
+cmake_minimum_required (VERSION 3.2.2)
PROJECT (HDF5_HL C CXX)
#-----------------------------------------------------------------------------
@@ -17,16 +17,16 @@ add_subdirectory (${HDF5_HL_SOURCE_DIR}/src ${HDF5_HL_BINARY_DIR}/src)
#-- Build the High level Tools
if (HDF5_BUILD_TOOLS)
add_subdirectory (${HDF5_HL_SOURCE_DIR}/tools ${HDF5_HL_BINARY_DIR}/tools)
-endif (HDF5_BUILD_TOOLS)
+endif ()
#-- Add High Level Examples
if (HDF5_BUILD_EXAMPLES)
add_subdirectory (${HDF5_HL_SOURCE_DIR}/examples ${HDF5_HL_BINARY_DIR}/examples)
-endif (HDF5_BUILD_EXAMPLES)
+endif ()
#-- Build the Unit testing if requested
if (NOT HDF5_EXTERNALLY_CONFIGURED)
if (BUILD_TESTING)
add_subdirectory (${HDF5_HL_SOURCE_DIR}/test ${HDF5_HL_BINARY_DIR}/test)
- endif (BUILD_TESTING)
-endif (NOT HDF5_EXTERNALLY_CONFIGURED)
+ endif ()
+endif ()